CentOS 6.5安装aria2

由于yum install aria2无法找到安装包,试了好几个源,都找不到,于是自己找了一些地址:

1、下载安装包:

# wget http://ftp.tu-chemnitz.de/pub/linux/dag/redhat/el6/en/x86_64/rpmforge/RPMS/aria2-1.16.4-1.el6.rf.x86_64.rpm

# wget http://ftp.tu-chemnitz.de/pub/linux/dag/redhat/el6/en/x86_64/rpmforge/RPMS/nettle-2.2-1.el6.rf.x86_64.rpm

# wget http://ftp.tu-chemnitz.de/pub/linux/dag/redhat/el6/en/x86_64/rpmforge/RPMS/nettle-devel-2.2-1.el6.rf.x86_64.rpm

2、安装

安装aria2时会提示

error: Failed dependencies:
libnettle.so.4()(64bit) is needed by aria2-1.16.4-1.el6.rf.x86_64

所以,需要先安装nettle-2.2.1,依次执行以下安装命令即可:

# rpm -ivh nettle-2.2-1.el6.rf.x86_64.rpm

# rpm -ivh nettle-devel-2.2-1.el6.rf.x86_64.rpm

# rpm -ivh aria2-1.16.4-1.el6.rf.x86_64.rpm

3、测试(下载百度首页)

# aria2c http://www.baidu.com

05/23 00:00:13 [NOTICE] Download complete: /home/root/index.html

Download Results:
gid |stat|avg speed |path/URI
======+====+===========+=======================================================
678b8e|OK | 0.9MiB/s|/home/root/index.html

Status Legend:
(OK):download completed.

【上一篇】: 【下一篇】:

0 Comments.